After SU6, Skyelite 1.3 did not show ETE, Distance, Waypoints.

Did a GPS direct to Flight from Paderborn/Lippstadt to Muenster/Osnabrück EDDG from the New Flight Window in the SIM. Not from the G1000 in the Plane. Plane was the 172 with Standard G1000.
The complete Flight Path was shown on the Map and the Distance to the First Waypoint (in Skyelite). Started the Flight, first Waypoint was passed without Autopilot and after passing 1000 Feet i engaged Autopilot (NAV Mode, CDI to GPS). The Plane followed the Path but in Skyelite only the Distance to the first Waypoint was shown. No updates in Distance or ETE. Changing the G1000 in the SIM between NAV1, NAV2 and GPS was shown in Skyelite but the Waypoint has only 3 Digits, EDD instead of EDDG. The Position of the Plane in the Map is shown. In Skyelite, the Plane follows the Path.
Same with the G1000 NXI. Is it the SIM or Skyelite?
Originally Posted by: meierzwo 

Same with the G1000 NXI. Is it the SIM or Skyelite?

If the same happens in G1000 NXi, it sounds like a SIM or interface issue, I will test a full fly later or tomorrow and let you know,

Some users also reported issues after installing G1000 NXi, not sure if that mod changes something in the system.

Also, could be great if you can send me a copy of the flight plan used by private message so I will use the same test.

Questions please: No updates in Distance or ETE means in the PFD or in the flight plan screen?


I just tested with 172 G1000 and everything is ok on my side

 ete.jpg You have insufficient rights to see the content.

I don't have the G1000 NXi mod installed so just wondering if that is the one causing the issue, you can temporary uninstall it and see if makes any difference.

Flight was VFR Direct GPS- Paderborn EDLP Gate 3 to Muenster/Osnabrueck EDDG. I checked both G1000, Standard and NXI. Both with the same result. No Distance and ETE is on the "MFD" Flight Plan Screen.
Maybe some AddOns cause that Glitch. I will do some Checks tomorrow.
Okay, it's the G1000 NXI. With Stock G1000, it worked.

The only Glitch with the G1000 after one of the SIM Updates is, it shows TIMECLI and TIMEAPP instead of the Waypoint or Destination if the Flight is started out of the New Flight Window.

With the NXI, the Map in SkyElite shows only a 3 Digit Destination.

There are some Differences.
G1000 starts with NAV1, and you have to change to GPS.
The NXI starts with GPS and Skyelite shows the 3 Digit Destination instead of the correct 4 Digit one. It noticed the switching between NAV1, NAV2 and GPS but in GPS, it stays with the 3 Digit Destination. Looks like something in the Data Stream is different. Choosing the Destination Airport in the Skyelite Map and activating MPT, ETE and Distance will come up in the Map. So the necessary Information is there.
Maybe you will have a look for a future Update so Skyelite will work with the G1000 NXI too.

Best regards
I expected this was caused by the G1000 NXi because few users reported other different problems with that mod too.

Just a small clarification: There is nothing to update or fix in SkyElite to make it work with G1000 NXi, because SkyElite is showing the values of the SimConnect interface variables as they are, without any alterations, and there is no workaround on this.

If the G1000 NXi mod is changing the way that SimConnect interface works or how the values are shown... it should be them the ones to fix it.

There are some developers changing lot of standard functions to make their mods operational, and that affects negatively to other tools or mods. But the issue is on them not on us.

Thank you for the information!
Any news on this front? I'm certain we're not gonna get working title to redesign their stuff as it's the now the defacto GPS for flight sim and having skyelite not working to its fullest isn't great when most users with this are likely to have the nxi as well.

Not saying you should pivot because of external stuff but it kinda makes sense in this case no?
Working Title mods are not affecting directly to SkyElite, are affecting some of the MS SimConnect Interface features.

I'm not saying it is breaking it all, but some piece of software developed in their system is changing the way some information is shown in the SimConnect GPS system.

This means that all the software using SimConnect interface will be affected by this issue. Not only SkyElite. You can use several tools and maps connected to the simulator through SimConnect and all of them are suffering the same issues when Working Title mods are installed.

I explained this in here and other forums several times, I know its frustrating and I also know that maybe asking Working Title to fix this is going to lead nowhere... probably. But there is nothing that any SimConnect-depending developer can do on his side, neither do I.

Is not a matter of if I want or I don't want, only the ones causing this issue can fix it, because is in their code, not in mine.

So far, the only possible solution is to temporary disable Working Title mods while using not only SkyElite, but all other SimConnect apps affected in the same way... or also... use both together but accept that few information will be differing from one system to the other.